
Transient analysis

11

Chapter overview
This chapter describes how to set up a transient analysis 
and includes the following sections:

• Overview of transient analysis on page 340

• Defining a time-based stimulus on page 342

• Transient (time) response on page 353

• Internal time steps in transient analyses on page 356

• Switching circuits in transient analyses on page 357

• Plotting hysteresis curves on page 357

• Fourier components on page 359
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Overview of transient analysis

Minimum requirements to run a transient analysis

Minimum circuit design requirements
Circuit should contain one of the following:

• An independent source with a transient specification 
(see Table 31)

• An initial condition on a reactive element

• A controlled source that is a function of time

Minimum program setup requirements
1 From the PSpice menu, choose New Simulation 

Profile or Edit Simulation Settings. (If this is a new 
simulation, enter the name of the profile and click 
OK.)

The Simulation Settings dialog box appears.

2 From the Analysis type list box, select Time Domain 
(Transient).

3 Specify the required parameters for the transient 
analysis you want to run.

4 Click OK to save the simulation profile.

5 From the PSpice menu, choose Run to start the 
simulation.

See Setting up analyses on page 282 for a 
description of the Analysis Setup dialog 
box.
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Defining a time-based stimulus 

Overview of stimulus generation
Symbols that generate input signals for your circuit can be 
divided into two categories:

• those whose transient behavior is characterized 
graphically using the Stimulus Editor

• those whose transient behavior is characterized by 
manually defining their properties within Capture

Their symbols are summarized in Table 31.

Table 31 Stimulus symbols for time-based input signals

Specified by... Symbol name Description

Using the 
Stimulus Editor

VSTIM voltage source

ISTIM current source

DIGSTIM1

DIGSTIM2

DIGSTIM4

DIGSTIM8

DIGSTIM16

DIGSTIM32

digital stimuli

Defining symbol 
attribute

VSRC
VEXP
VPULSE
VPWL
VPWL_RE_FOREVER
VPWL_F_RE_FOREVER
VPWL_N_TIMES
VPWL_F_N_TIMES
VSFFM
VSIN

voltage sources

Note The Stimulus Editor is 
not included in PSpice A/D 
Basics.
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To use any of these source types, you must place the 
symbol in your schematic and then define its transient 
behavior. 

Each property-characterized stimulus has a distinct set of 
attributes depending upon the kind of transient behavior 
it represents. For VPWL_F_xxx, IPWL_F_xxx, and FSTIM, 
a separate file contains the stimulus specification.

As an alternative, the Stimulus Editor utility automates 
the process of defining the transient behavior of stimulus 
devices. The Stimulus Editor allows you to create analog 
stimuli which generate sine wave, repeating pulse, 
exponential pulse, single-frequency FM, and piecewise 
linear waveforms. It also facilitates creating digital stimuli 
with complex timing relations. This applies to both 
stimulus symbols placed in your schematic as well as new 
ones that you might create.

ISRC
IEXP
IPULSE
IPWL
IPWL_RE_FOREVER
IPWL_F_RE_FOREVER
IPWL_N_TIMES
IPWL_F_N_TIMES
ISFFM
ISIN

current sources

DIGCLOCK digital clock signal

STIM1
STIM4
STIM8
STIM16

digital stimuli

FILESTIM1

FILESTIM2

FILESTIM4

FILESTIM8

FILESTIM16

FILESTIM32

digital file stimuli

Table 31 Stimulus symbols for time-based input signals 

Specified by... Symbol name Description

 For information on digital stimuli 
characterized by property, see Chapter 14, 
Digital simulation.
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The stimulus specification created using the Stimulus 
Editor is saved to a file, automatically configured into the 
schematic, and associated with the corresponding VSTIM, 
ISTIM, or DIGSTIM part instance or symbol definition.

The Stimulus Editor utility 
The Stimulus Editor is a utility that allows you to quickly 
set up and verify the input waveforms for a transient 
analysis. You can create and edit voltage sources, current 
sources, and digital stimuli for your circuit. Menu 
prompts guide you to provide the necessary parameters, 
such as the rise time, fall time, and period of an analog 
repeating pulse, or the complex timing relations with 
repeating segments of a digital stimulus. Graphical 
feedback allows you to quickly verify the waveform.

Stimulus files
The Stimulus Editor produces a file containing the stimuli 
with their transient specification. These stimuli are 
defined as simulator device declarations using the V 
(voltage source), I (current source), and U STIM (digital 
stimulus generator) forms. Since the Stimulus Editor 
produces these statements automatically, you will never 
have to be concerned with their syntax. However, if you 
are interested in a detailed description of their syntax, see 
the descriptions of V and I devices in the Analog Devices 
chapter and stimulus generator in the Digital Devices 
chapter of the the online OrCAD PSpice A/D Reference 
Manual.

Note The Stimulus Editor is 
not included in PSpice A/D 
Basics.

OrCAD program versions without the 
Stimulus Editor must use the 
characterized-by-property sources listed in 
Table 31 on page 342.
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Configuring stimulus files
The Include Files tab in the Simulation Settings dialog box 
allows you to view the list of stimulus files pertaining to 
your current schematic. You can also manually add, 
delete, or change the stimulus file configuration in this tab 
dialog box. The list box displays all of the currently 
configured stimulus files. One file is specified per line. 
Files can be configured as either global to the Capture 
environment or local to the current design. Global files are 
marked with an asterisk (*) after the file name.

When starting the Stimulus Editor from Capture, stimulus 
files are automatically configured (added to the list) as 
local to the current design. Otherwise, new stimulus files 
can be added to the list by entering the file name in the 
Filename text box and then clicking the Add to design 
(local configuration) or Add as global (global 
configuration) button.

Starting the Stimulus Editor
The Stimulus Editor is fully integrated with Capture and 
can be run from either the schematic editor or symbol 
editor.

You can start the Stimulus Editor by doing the following:

1 Select one or more stimulus instances in the schematic

2 From the Edit menu, choose PSpice Stimulus.

When you first start the Stimulus Editor, you may need to 
adjust the scale settings to fit the trace you are going to 
add. You can use Axis Settings on the Plot menu or the 
corresponding toolbar button to change the displayed 
data, the extent of the scrolling region, and the minimum 
resolution for each of the axes. Displayed Data Range 
parameters determine what portion of the stimulus data 
set will be presented on the screen. Extent of Scrolling 
Region parameters set the absolute limits on the viewable 
range. Minimum Resolution parameters determine the 
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smallest usable increment (example: if it is set to 1 msec, 
then you cannot add a data point at 1.5 msec).

Defining stimuli
1 Place stimulus part instances from the symbol set: 

VSTIM, ISTIM and DIGSTIMn (found in the 
SOURCESTM.OLB part library).

2 Click the source instance to select it.

3 From the Edit menu, choose PSpice Stimulus to start 
the Stimulus Editor. 

4 Fill in the transient specification according to the 
dialogs and prompts. 

Piecewise linear and digital stimuli can be specified by 
direct manipulation of the input waveform display.

5 From the File menu, choose Save to save the edits.

Example: piecewise linear stimulus
1 Open an existing schematic or start a new one.

2 From the Place menu, choose Part and browse the 
SOURCESTM.OLB part library file for VSTIM (and 
select it).

3 Place the part. It looks like a regular voltage source 
with an implementation property displayed.

4 Click the implementation label and type Vfirst. This 
names the stimulus that you are going to create.

5 If you are working in a new schematic, use Save from 
the File menu to save it. This is necessary since the 
schematic name is used to create the default stimulus 
file name.

6 Click the VSTIM part to select it.

7 From the Edit menu, choose PSpice Stimulus. This 
starts the Stimulus Editor and displays the New 

See Chapter 14, Digital simulation, for 
detailed information about creating digital 
stimuli.
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Stimulus dialog box. You can see that the stimulus 
already has the name of Vfirst.

8 Select PWL in the dialog box and click OK. The cursor 
looks like a pencil. The message in the status bar at the 
bottom of the screen lets you know that you are in the 
process of adding new data points to the stimulus. The 
left end of the bottom status bar displays the current 
coordinates of the cursor.

9 Move the cursor to (200ns, 1) and click the left mouse 
button. This adds the point. Notice that there is 
automatically a point at (0,0). Ignore it for now and 
continue to add a couple more points to the right of the 
current one. 

10 Click-right to stop adding points.

11 From the File menu, choose Save.

If you make a mistake or want to make any changes, 
reshape the trace by dragging any of the handles to a new 
location. The dragged handle cannot pass any other 
defined data point.

To delete a point, click its handle and press X. 

To add additional points, either choose Add Point from 
the Edit menu, press A+A, or click the Add Point 
toolbar button. 

At this point you can return to Capture, edit the current 
stimulus, or go on to create another.

Example: sine wave sweep
1 Open an existing schematic or start a new one.

2 Place a VSTIM part on your schematic.

3 To name the stimulus, double-click the 
implementation property and type Vsin.

4 Click the VSTIM part to select it.

5 From the PSpice menu, choose Edit Stimulus to start 
the Stimulus Editor.

This example creates a 10 k sine wave with 
the amplitude parameterized so that it can 
be swept during a simulation.
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6 Define the stimulus parameter for amplitude:

a From the New Stimulus dialog box, choose Cancel. 

b From the Tools menu, choose Parameters.

c Enter AMP=1 in the Definition text box, and click 
OK.

d From the Stimulus menu, choose New or click the 
New Stimulus button in the toolbar.

e Give the stimulus the name of Vsin.

f Select SIN as the type of stimulus to be created, 
and click OK.

7 Define the other stimulus properties:

a Enter 0 for Offset Value.

b Enter {AMP} for Amplitude. The curly braces are 
required. They indicate that the expression needs 
to be evaluated at simulation time.

c Enter 10k for Frequency and click OK.

d From the File menu, choose Save.

8 Within Capture, place and define the PARAM symbol:

a From the Place menu, choose Part.

b Either browse SPECIAL.OLB for the PARAM part 
or type in the name.

c Place the part on your schematic and double-click 
it.

d Click New to add a new user property.

e Set the value property name to AMP (no curly 
braces).

f Set the value of the VALUE1 property to 1.

9 Set up the parametric sweep and other analyses:

a From the PSpice menu, choose Stimulus Editor, 
and click the Parametric Sweep button.

b Select Global Parameter in the Swept Var. Type 
frame.
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c Select Linear in the Sweep type frame.

10 Enter AMP in the Name text box.

11 Specify values for the Start Value, End Value, and 
Increment text boxes.

You can now set up your usual Transient, AC, or DC 
analysis and run the simulation.

Creating new stimulus symbols
1 Use the Capture part editor to edit or create a part with 

the following properties:

Implementation Type PSpice Stimulus

Implementation name of the stimulus model

STIMTYPE type of stimulus; valid values 
are ANALOG or DIGITAL; if 
this property is nonexistent, the 
stimulus is assumed to be 
ANALOG
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Editing a stimulus

To edit an existing stimulus
1 Start the Stimulus Editor and select Get from the 

Stimulus menu.

2 Double-click the trace name (at the bottom of the X 
axis for analog and to the left of the Y axis for digital 
traces.) This opens the Stimulus Attributes dialog box 
where you can modify the attributes of the stimulus 
directly and immediately see the effect of the changes.

To edit a PWL stimulus
1 Double click the trace name. This displays the handles 

for each defined data point.

2 Click any handle to select it. To reshape the trace, drag 
it to a new location. To delete the data point, press X.

3 To add additional data points, either select Add from 
the Edit menu or click the Add Point button. 

4 Right-click to end adding new points.

To select a time and value scale factor for PWL 
stimuli
1 Select the PWL trace by clicking on its name.

2 Select Attributes from the Edit menu or click the 
corresponding toolbar button.

PWL stimuli are a little different since they 
are a series of time/value pairs.

This provides a fast way to scale a PWL 
stimulus.
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Deleting and removing traces
To delete a trace from the displayed screen, select the trace 
name by clicking on its name, then press X. This will 
only erase the display of the trace, not delete it from your 
file. The trace is still available by selecting Get from the 
Stimulus menu.

To remove a trace from a file, select Remove from the 
Stimulus menu. 

Note Once a trace is removed, it is no longer retrievable. Delete traces 
with caution.

Manual stimulus configuration
Stimuli can be characterized by manually starting the 
Stimulus Editor and saving their specifications to a file. 
These stimulus specifications can then be associated to 
stimulus instances in your schematic or to stimulus 
symbols in the symbol library. 

To manually configure a stimulus
1 Start the Stimulus Editor by double-clicking on the 

Stimulus Editor icon in the OrCAD program group.

2 Open a stimulus file by selecting Open from the File 
menu. If the file is not found in your current library 
search path, you are prompted for a new file name.

3 Create one or more stimuli to be used in your 
schematic. For each stimulus:

a Name it whatever you want. This name will be 
used to associate the stimulus specification to the 
stimulus instance in your schematic, or to the 
symbol in the symbol library.

b Provide the transient specification.

c From the File menu, choose Save.
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4 In the schematic page editor, configure the Stimulus 
Editor’s output file into your schematic:

a From the Pspice menu, choose Edit Simulation 
Settings.

a In the Simulation Settings dialog box, select the 
Include Files tab.

b Enter the file name specified in step 2.

c If the stimulus specifications are for local use in the 
current design, click the Add to design button. For 
global use by any design, use Add as global 
instead.

d Click OK.

5 Modify either the stimulus instances in the schematic 
or symbols in the symbol library to reference the new 
stimulus specification.

6 Associate the transient stimulus specification to a 
stimulus instance:

a Place a stimulus part in your schematic from the 
part set: VSTIM, ISTIM, and DIGSTIMn.

b Click the VSTIM, ISTIM, or DIGSTIMn instance.

c From the Edit menu, choose Properties.

d Click the Implementation cell, type in the name of 
the stimulus, and click Apply.

e Complete specification of any VSTIM or ISTIM 
instances by selecting Properties from the Edit 
menu and editing their DC and AC attributes.

Click the DC cell and type its value.

Click the AC cell, type its value, and then click 
Apply.

f Close the property editor spreadsheet.
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7 To change stimulus references globally for a part:

a Select the part you want to edit.

a From the Edit menu, choose Part to start the part 
editor.

b Create or change the part definition, making sure 
to define the following properties:

Transient (time) response
The Transient response analysis causes the response of the 
circuit to be calculated from TIME = 0 to a specified time. 
A transient analysis specification is shown for the circuit 
EXAMPLE.OPJ in Figure 64. (EXAMPLE.OPJ is shown in 
Figure 65.)

The analysis is to span the time interval from 0 to 1000 
nanoseconds and values should be reported to the 
simulation output file every 20 nanoseconds.

Implementation stimulus name as defined in 
the Stimulus Editor

See Chapter 5, Creating parts for models, 
for a description of how to create and edit 
parts.

Note Transient (time) 
response analysis is not 
supported in PSpice A/D 
Basics.
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During a transient analysis, any or all of the independent 
sources may have time-varying values. In EXAMPLE.OPJ, 
the only source which has a time-varying value is V1 
(VSIN part) with attributes:

VOFF = 0v
VAMPL = 0.1v
FREQ = 5Meg

V1’s value varies as a 5 MHz sine wave with an offset 
voltage of 0 volts and a peak amplitude of 0.1 volts. In 
general, more than one source has time-varying values; 
for instance, two or more clocks in a digital circuit.

Figure  64 Transient analysis setup for EXAMPLE.OPJ.
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Figure 65 Example schematic EXAMPLE.OPJ.

The transient analysis does its own calculation of a bias 
point to start with, using the same technique as described 
for DC sweep. This is necessary because the initial values 
of the sources can be different from their DC values. To 
report the small-signal parameters for the transient bias 
point, use the Transient command and enable Detailed 
Bias Point. Otherwise, if you simply want the result of the 
transient run itself, you should only enable the Transient 
command.

In the simulation output file EXAMPLE.OUT, the 
bias-point report for the transient bias point is labeled 
INITIAL TRANSIENT SOLUTION. 

The example circuit EXAMPLE.OPJ is 
provided with the OrCAD program 
installation.
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Internal time steps in transient 
analyses
During analog analysis, PSpice A/D maintains an internal 
time step which is continuously adjusted to maintain 
accuracy while not performing unnecessary steps. During 
periods of inactivity, the internal time step is increased. 
During active regions, it is decreased. The maximum 
internal step size can be controlled by specifying it in the 
Step Ceiling text box in the Transient dialog box. 
PSpice A/D will never exceed either the step ceiling value 
or two percent of the total transient run time, whichever is 
less.

The internal time steps used may not correspond to the 
time steps at which information has been requested to be 
reported. The values at the print time steps are obtained 
by second-order polynomial interpolation from values at 
the internal steps.

When simulating mixed analog/digital circuits, there are 
actually two time steps: one analog and one digital. This is 
necessary for efficiency. Since the analog and digital 
circuitry usually have very different time constants, any 
attempt to lock them together would greatly slow down 
the simulation. The time step shown on the PSpice A/D 
display during a transient analysis is that of the analog 
section.

See Chapter 14, Digital simulation, for 
more information on the digital timing 
analysis of PSpice A/D.
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Switching circuits in transient 
analyses
Running transient analysis on switching circuits can lead 
to long run times. PSpice A/D must keep the internal time 
step short compared to the switching period, but the 
circuit’s response extends over many switching cycles.

One method of avoiding this problem is to transform the 
switching circuit into an equivalent circuit without 
switching. The equivalent circuit represents a sort of quasi 
steady-state of the actual circuit and can correctly model 
the actual circuit’s response as long as the inputs do not 
change too fast.

Plotting hysteresis curves
Transient analysis can be used to look at a circuit’s 
hysteresis. Consider, for instance, the circuit shown in 
Figure 66 (netlist in Figure 67).

Figure 66 ECL-compatible Schmitt trigger.

This technique is described in:

V. Bello, “Computer Program Adds SPICE to 
Switching-Regulator Analysis,” Electronic 
Design, March 5, 1981.
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The QSTD model is defined as:

.MODEL QSTD NPN( is=1e-16 bf=50 br=0.1 rb=50 rc=10 
tf=.12ns tr=5ns

+ cje=.4pF pe=.8 me=.4 cjc=.5pF pc=.8 mc=.333 ccs=1pF 
va=50)

Instead of using the DC sweep to look at the hysteresis, 
use the transient analysis, (Print Step = .01ms and Final 
Time = 2ms) sweeping VIN from -1.8 volts to -1.0 volts 
and back down to -1.8 volts, very slowly. This has two 
advantages:

• it avoids convergence problems

• it covers both the upward and downward transitions 
in one analysis

After the simulation, in the Probe window in PSpice A/D, 
the X axis variable is initially set to be Time. By selecting 
X Axis Settings from the Plot menu and clicking on the 
Axis Variable button, you can set the X axis variable to be 
V(1). Then use Add on the Trace menu to display V(7), 
and change the X axis to a user defined data range from 
-1.8V to -1.0V (Axis Settings on the Plot menu). This plots 
the output of the Schmitt trigger against its input, which is 
the desired outcome. The result looks similar to Figure 68.

Figure 67 Netlist for Schmitt trigger circuit.

* Capture Netlist

R_RIN 1 2 50
R_RC1 0 3 50
R_R1 3 5 185
R_R2 5 8 760
R_RC2 0 6 100
R_RE 4 8 260
R_RTH2 7 0 85
C_CLOAD 0 7 5PF
V_VEE 8 0 dc -5
V_VIN 1 0
+PWL 0 -8 1MS -1.0V 2MS -1.8V
R_RTH1 8 7 125
Q_Q1 3 2 4 QSTD
Q_Q2 6 5 4 QSTD
Q_Q3 0 6 7 QSTD
Q_Q4 0 6 7 QSTD

Pspug.book  Page 358  Tuesday, November 2, 1999  2:29 PM



Fourier components

359

Figure 68 Hysteresis curve example: Schmitt trigger.

Fourier components
Fourier analysis is enabled through the Output File 
Options dialog box under the Time Domain (Transient) 
Analysis type. Fourier analysis calculates the DC and 
Fourier components of the result of a transient analysis. 
By default, the first through ninth components are 
computed; however, more can be specified.

When selecting Fourier to run a harmonic decomposition 
analysis on a transient waveform, only a portion of the 
waveform is used. Using the Probe window in PSpice 
A/D, a Fast Fourier Transform (FFT) of the complete 
waveform can be calculated and its spectrum displayed.

In the example shown in Figure 64 on page 354, the 
voltage waveform at node OUT2 from the transient 
analysis is to be used and the fundamental frequency is to 
be one megahertz for the harmonic decomposition. The 
period of fundamental frequency is one microsecond 
(inverse of the fundamental frequency). Only the last one 
microsecond of the transient analysis is used, and that 

Note You must do a transient analysis 
in order to do a Fourier analysis. The 
sampling interval used during the 
Fourier transform is equal to the print 
step specified for the transient analysis.
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portion is assumed to repeat indefinitely. Since V1’s sine 
wave does indeed repeat every one microsecond, this is 
sufficient. In general, however, you must make sure that 
the fundamental Fourier period fits the waveform in the 
transient analysis.
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